SnippetMaster Support Forums

General => General Discussion & Support => Topic started by: harringg on February 13, 2008, 07:17:58 AM



Title: Newbie-WYSIWYG
Post by: harringg on February 13, 2008, 07:17:58 AM
I've just installed the Lite version and last night while editing, all was fine.  I had the WYSIWYG editor.  Now when I login, I get just text on my SnippetMaster page, and when I click on the index.html under Whole files, it gives me an option to toggle, but nothing happens.  Zend install on my server.

Thanks,
harringg

Edit:  Something else must be going on.  When I do have just the code view and I make a change and Save (I'm logged in as administrator), it goes back to ask me to select a page.

Edit: the page is a basic html page, <html><body>relevant snippet code goes here</body></html>


Title: Re: Newbie-WYSIWYG
Post by: thor0128 on February 13, 2008, 03:19:35 PM
I am having some issues with the WYSIWYG (I have a Pro version), trying to put in a link to a page (external web link). I highlight the text in the tool click on the link icon, input the address but the popup does not work the way the documentation says. Basically I can setup and link on highlighted test and have it work...

any help would be great!  :o :shock:


Title: Re: Newbie-WYSIWYG
Post by: admin on February 13, 2008, 03:34:28 PM
Hi guys,

From what I can see, each of these issues is something I'll need to login to your Snippetmaster instllation to test out and get more info.  Can you send me an email with a link to this thread, and then exact "step by step" instructions to recreate the problem?  This way, I can quickly login, confirm the issue, and then start trying to figure out what is the cause and the fix.  :)  (henri@snippetmaster.com)

Thanks!


Title: Re: Newbie-WYSIWYG
Post by: thor0128 on February 13, 2008, 03:44:10 PM
you have got mail...


Title: Re: Newbie-WYSIWYG
Post by: admin on February 13, 2008, 03:46:57 PM
Hello,

The javascript errors you are seeing should definately not be there.  Does this work for you when you try the demo here:

http://www.snippetmaster.com/demo/

If the demo works for you, then I think the problem is with your installation.  Maybe a configuration issue or missing/corrupted file or something.  If the demo does not work for you, then it might be your browser?  (Try it with firefox, and see?)

Let me know.


Title: Re: Newbie-WYSIWYG
Post by: admin on February 13, 2008, 03:48:04 PM
Also... there might be an issue with "gzip" on your server.  Can you try disabling that option in Snippetmaster and see if that changes anything?

1. Login as admin user.
2. Click the "admin" link.
3. Choose the "general" tab.
4. Find the "enable gzip compression" option, and disable it.



Title: Re: Newbie-WYSIWYG
Post by: thor0128 on February 13, 2008, 03:57:29 PM
nope it does not work on the demo page either.. tried both Safari and FireFox, same errors as on my site...


Title: Re: Newbie-WYSIWYG
Post by: admin on February 13, 2008, 03:59:15 PM
That's very interesting.  It works fine for me, with both firefox and IE.  (Safari is hit and miss...)

OK.. can you try disabling the gzip compression feature for your site and see if that does the trick?



Title: Re: Newbie-WYSIWYG
Post by: thor0128 on February 13, 2008, 04:00:22 PM
don't see the gzip option either.


Title: Re: Newbie-WYSIWYG
Post by: admin on February 13, 2008, 04:05:16 PM
don't see the gzip option either.

It is the option in the General tab called, "Enable Editor Compression".

1. Login as admin user.
2. Click the "admin" link.
3. Choose the "general" tab.
4. Find the "Enable Editor Compression" option, and disable it.


Title: Re: Newbie-WYSIWYG
Post by: thor0128 on February 13, 2008, 04:08:51 PM
I don't see the gzip on the demo page either.

Duh found it an set it to no!


Title: Re: Newbie-WYSIWYG
Post by: admin on February 13, 2008, 04:10:05 PM
I don't see the gzip on the demo page either.

It's definately there. 

It is the option in the General tab called, "Enable Editor Compression".

1. Login as admin user.
2. Click the "admin" link.
3. Choose the "general" tab.
4. Find the "Enable Editor Compression" option, and disable it.



Title: Re: Newbie-WYSIWYG
Post by: thor0128 on February 13, 2008, 04:19:20 PM
okay that compression issue seem to be the problem. I have noticed another bug, when I insert and picture it wipes out my links.... I am learning. Okay user cockpit error...


Title: Re: Newbie-WYSIWYG
Post by: admin on February 13, 2008, 04:22:02 PM
It should not be kiilling your links. Can you give me exact instructions to recreate the problem? 


Title: Re: Newbie-WYSIWYG
Post by: thor0128 on February 13, 2008, 04:28:11 PM
it was operator error, I put the photo right on top of the text duh  :lol:


Title: Re: Newbie-WYSIWYG
Post by: harringg on February 13, 2008, 04:30:52 PM
I don't see the gzip on the demo page either.

It's definately there. 

It is the option in the General tab called, "Enable Editor Compression".

1. Login as admin user.
2. Click the "admin" link.
3. Choose the "general" tab.
4. Find the "Enable Editor Compression" option, and disable it.



I turned that off and don't see any improvements.  Yes, WYSIWYG is enabled in General too.  One odd thing I'm seeing is Javascript is not responding on that site.  I've got FF with NoScript and it's enabled (always allow).  When I mouse over the ? icons nothing pops up.  Not sure what changed between yesterday and today.  Other sites Javascript "works".

Edit:  Your demo page works in FF 2.0.0.12, NoScript is v1.3.2, my site doesn't.  In Safari, my page works as expected.

Mac OS 10.4.11


Title: Re: Newbie-WYSIWYG
Post by: admin on February 13, 2008, 04:37:15 PM
OK, can you send me an email with exact instructions to recreate the problem?  henri@snippetmaster.com

(ie: Link to this thread, snippetmaster un/pw, and specific "how to" steps to recreate the problem.)

Actually, before you do that.. can you navigate into the /snippetmaster/ folder on your installation and try to load one of the example files for editing?  See if that works.  Maybe it is something on your page code that is causing the problem?  The example files are known working order, so if they don't work, then the problem is elsewhere.

Thanks.


Title: Re: Newbie-WYSIWYG
Post by: harringg on February 13, 2008, 04:43:00 PM
OK, can you send me an email with exact instructions to recreate the problem?  henri@snippetmaster.com

(ie: Link to this thread, snippetmaster un/pw, and specific "how to" steps to recreate the problem.)

Actually, before you do that.. can you navigate into the /snippetmaster/ folder on your installation and try to load one of the example files for editing?  See if that works.  Maybe it is something on your page code that is causing the problem?  The example files are known working order, so if they don't work, then the problem is elsewhere.

Thanks.

No WYSIWYG on those pages.  I did send you an email earlier, from elists@gh......


Title: Re: Newbie-WYSIWYG
Post by: admin on February 13, 2008, 04:47:05 PM
Ah.. I see your email here now.  Sorry about that.  (I get about 400 emails a day...)

OK, I'll take a look and work with you via email to figure this out.  :)


Title: Re: Newbie-WYSIWYG
Post by: thor0128 on February 13, 2008, 06:20:43 PM
okay stump the dummy, It seems that FF 2.0.12 does not allow copy and paste via TinyMCE.. via my mac any ideas?
 :shock:  :(


Title: Re: Newbie-WYSIWYG
Post by: admin on February 13, 2008, 06:26:56 PM
Hmm.. this is most likely a MAC setting somewhere.  It's probably in the security settings of firefox?



Title: Re: Newbie-WYSIWYG
Post by: thor0128 on February 13, 2008, 06:31:25 PM
Nope I have checked there.. still hunting...


Title: Re: Newbie-WYSIWYG
Post by: harringg on February 13, 2008, 06:31:54 PM
okay stump the dummy, It seems that FF 2.0.12 does not allow copy and paste via TinyMCE.. via my mac any ideas?
 :shock:  :(
I just copy/pasted on the SnippetMaster demo page (admin/admin) in FF 2.0.12, Mac OS 10.4.11, but I don't get WYSIWYG on my own install in the same browser.  Go figure. :roll:

Edit:

My site works in FF 2.0.11 on my Intel iMac, but not my MacBook Pro and FF 2.0.112.  Very strange, but it points to a problem on my local system and I'll keep digging.  SnippetMaster looks like a great fit for current and future clients websites.

I would like to add a special thank you to Henri for his outstanding help, both here and off list.

Edit:  I got to thinking, NoScript versions are different on iMac and MacBookPro (computer I edit on), so I turned off the FF extension, v1.3.2, and went back in on the MacBook Pro and was able to edit my content as expected.  I know that No-Script blocks cross-scripting, would that have something to do with it?  I'm not versed enough in scripting to know the details.  Even though I have my site as a trusted site, it may be that something is pointing elsewhere "behind the scenes" in SnippetMaster's code.

At any rate, if I want to edit on my laptop, I'll just turn off that plug-in.

Glad that's resolved!


Title: Re: Newbie-WYSIWYG
Post by: thor0128 on February 13, 2008, 10:15:11 PM
I agree with you Grant. Henri thank you for all of your help! Snippetmaster is a great bit of kit (okay code). Are you planning on adding more to it? The big issue I am still seeing is with pages that have flash player code in them (okay I would not let someone change the flash bit of code), but it would be nice to not have that issue. What I have observed is that the flashplayer functions stop working (like the play buttons, fast forward, choosing hte next song, etc.).

Nothing is prefect but this is getting closer
 :lol: 8) :P

okay I got the FF 2.0.0.12 issue on Mac figured out.. you need to create a user.js file with this code in it

user_pref("capability.policy.policynames", "allowclipboard");
user_pref("capability.policy.allowclipboard.sites", "http://www.snippetmaster.com http://www.masaweb.info");
user_pref("capability.policy.allowclipboard.Clipboard.cutcopy", "allAccess");
user_pref("capability.policy.allowclipboard.Clipboard.paste", "allAccess");

the line with the "capability.policy.allowclipboard.sites" is the key you need to put all of the site in that you want in this bit of code (spaces between the site names). save the file as user.js and then put into the proper file folders and it works, FF security issues, got to love them...


Title: Re: Newbie-WYSIWYG
Post by: harringg on February 14, 2008, 07:58:03 PM

okay I got the FF 2.0.0.12 issue on Mac figured out.. you need to create a user.js file with this code in it

user_pref("capability.policy.policynames", "allowclipboard");
user_pref("capability.policy.allowclipboard.sites", "http://www.snippetmaster.com http://www.masaweb.info");
user_pref("capability.policy.allowclipboard.Clipboard.cutcopy", "allAccess");
user_pref("capability.policy.allowclipboard.Clipboard.paste", "allAccess");

the line with the "capability.policy.allowclipboard.sites" is the key you need to put all of the site in that you want in this bit of code (spaces between the site names). save the file as user.js and then put into the proper file folders and it works, FF security issues, got to love them...


Where does this go on the server?

mydomain.com/snippetmaster/users.js ?

Thanks


Title: Re: Newbie-WYSIWYG
Post by: admin on February 14, 2008, 08:24:00 PM

Where does this go on the server?

mydomain.com/snippetmaster/users.js ?

Thanks

I think it needs to go in a folder on your computer.  Here's a link I found to explain in detail what this file is and how it works:

http://kb.mozillazine.org/User.js_file



Title: Re: Newbie-WYSIWYG
Post by: thor0128 on February 14, 2008, 10:10:09 PM
sorry it goes on your MAC. I will find the folders for you.


Title: Re: Newbie-WYSIWYG
Post by: Jenkinhill on February 15, 2008, 02:33:37 AM
It seems that FF 2.0.12 does not allow copy and paste via TinyMCE.

This is a security setting.

You should still be able to use keyboard shortcuts (Ctrl+C or Ctrl+V) to copy and paste. Otherwise edit the chrome for Firefox, see here (http://googlesystem.blogspot.com/2006/10/enabling-copy-paste-for-google-office.html)


Title: Re: Newbie-WYSIWYG
Post by: harringg on February 15, 2008, 06:07:26 AM
It seems that FF 2.0.12 does not allow copy and paste via TinyMCE.

This is a security setting.

You should still be able to use keyboard shortcuts (Ctrl+C or Ctrl+V) to copy and paste. Otherwise edit the chrome for Firefox, see here (http://googlesystem.blogspot.com/2006/10/enabling-copy-paste-for-google-office.html)

Now that I've worked out the issues with NoScript ( I had an iFrame in my page and it was being blocked by NS, but it didn't tell me, I reset NS and then allowed all sites, and it works, Thanks to the NS developer's help with figuring this out), I'm able to edit as expected in SnippetMaster and TinyMCE on Firefox, copy/paste as well.  So all is good.

Thanks too to the help I got here....