SnippetMaster Support Forums
Return to main website
 
January 20, 2018, 04:43:54 PM
* Show unread posts since last visit.
* Show new replies to your posts.
Welcome, Guest. Please login or register.
Did you miss your activation email?
January 20, 2018, 04:43:54 PM

Login with username, password and session length
Search:  
Advanced search
* Home Help Search Login Register
SnippetMaster Support Forums  |  General  |  General Discussion & Support  |  Topic: The new "Auto-Installer" system is here! « previous next »
Pages: [1] Print
Author Topic: The new "Auto-Installer" system is here!  (Read 9793 times)
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] The new "Auto-Installer" system is here!
« on: April 13, 2006, 08:44:30 AM »

Hi everyone,

After successful testing by the "internal beta testing team" (thanks guys!), I am now releasing the new Auto-Installer<Auto-Installer<Install Now!<Snippetmaster Auto-Installer Instructions

** Make sure you already have already gone through the beta software "order" process and have your SnippetMaster beta testing license key handy for the new version.

1) Click this link here and download the Auto-Installer file to your computer. (Right click on the link and choose "Save Target As...<2) Using your FTP program, log into your web server and create a new folder where you want SnippetMaster to be installed (ie: make a folder called "snippetmasterV2" or "webeditor" or whatever...)

3) Upload the autoinstaller.php file INTO the new folder you just created.

4) Using your browser, go to the autoinstaller.php file and then follow the instructions.

Your comments and feedback are appreciated... let me know what you think!

Smile
« Last Edit: April 18, 2006, 06:32:28 PM by admin » Report to moderator   Logged
zwaluw

Posts: 16


[-] Re: Who wants to test the new "Auto-Uploader" system?
« Reply #1 on: April 15, 2006, 01:51:06 PM »

A reply here as well (domain Solas site, so we had some contact yet)

- Auto-uploader worked great and it's quick, very nice tool!   Very Happy
Only got confused about the version number (snippetmaster 2.0.17) and therefor wasn't sure the new version was installed.

Thanks.


Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: Who wants to test the new "Auto-Uploader" system?
« Reply #2 on: April 15, 2006, 02:46:38 PM »

Only got confused about the version number (snippetmaster 2.0.17) and therefor wasn't sure the new version was installed.

Fixed!  I totally forgot to update the version number for the last release. I have just released version 2.0.19 (uploading as I write, so wait a few minutes..), and I made sure to double check the version number this time.  Smack me if I forget again!

Smile
Report to moderator   Logged
zwaluw

Posts: 16


[-] Re: The new "Auto-Uploader" system is here!
« Reply #3 on: April 16, 2006, 01:45:48 AM »

« Last Edit: April 16, 2006, 01:49:34 AM by zwaluw » Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: The new "Auto-Uploader" system is here!
« Reply #4 on: April 16, 2006, 05:24:37 AM »


After all was finished I got the message to click the link to start the "update-wizard".
If I do so, it only starts snippetmaster, or is something going on in the background?

The database-info was still intact.


If you use the Auto-Uploader to download the newest version of SnippetMaster "on top of" an old version of Snippetmaster (ie: you already had snippetmaster installed), then the program will think you are doing an upgrade... What I will do for upgrades is have an "upgrade wizard" which will run any necessary database changes or other things like that.

For now.. the "upgrade wizard" doesn't exist... but it will eventually.  Smile
Report to moderator   Logged
GregorH

Posts: 27



WWW
[-] Re: The new "Auto-Uploader" system is here!
« Reply #5 on: April 16, 2006, 11:04:24 AM »

« Last Edit: April 16, 2006, 11:18:04 AM by GregorH » Report to moderator   Logged
genecap

Posts: 62


WWW
[-] The new "Auto-Uploader" Safe Mode ON- works
« Reply #6 on: April 16, 2006, 04:53:01 PM »

Henri, thanks for your help!
With Safe mode "on" at my server, I had to ftp and create the snippet-db/subfolder and 777 it.
ALSO, my WS FTP Pro program had no default ascii, or binary set for php files. After I set php to ascii mode (per your suggestion) the autouploader worked!
Report to moderator   Logged

.... Gene
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: The new "Auto-Uploader" system is here!
« Reply #7 on: April 17, 2006, 07:35:54 AM »

Hi guys,

I just uploaded a new version of the auto-uploader that should work great now for all safe_mode servers.  I had to rewrite practically the entire unzip/ftp system, but it'll be worth it if the auploader will work on all safe_mode servers now.

Can you test it out and let me know how it goes? 

Thanks!
Report to moderator   Logged
zwaluw

Posts: 16


[-] Re: The new "Auto-Uploader" system is here!
« Reply #8 on: April 17, 2006, 11:17:26 AM »

Worked fine! No problem at all, but the previous version worked fine as well.

Thanks.
Report to moderator   Logged
dbowling

Posts: 5


[-] Re: The new "Auto-Uploader" system is here!
« Reply #9 on: April 17, 2006, 11:32:16 AM »

Worked great with mine, after I set it to passive. I think I'll make a suggestion though, the script didn't tell me to try again using passive mode until after pages of errors. A lay user would have skipped this section. Perhaps an error summary at the top might help these users?
Report to moderator   Logged
dtanderson

Posts: 11


WWW
[-] Re: The new "Auto-Uploader" system is here!
« Reply #10 on: April 17, 2006, 11:39:27 AM »

Hi there,

I have been a bit relapse and not done much testing lately (oops!)

But I have run the autouploader which is really fast!

However, I am not sure what to do about the license key. I have got as far as "SnippetMaster Installation (Part 2) - Install Wizard". But I get the message "The license key you entered is either not valid or a connection to the licensing server was not possible." Do I copy the whole license into the "license key" box, or what?

David Anderson
Report to moderator   Logged

dtanderson

Posts: 11


WWW
[-] Re: The new "Auto-Uploader" system is here!
« Reply #11 on: April 17, 2006, 11:59:12 AM »

Ignore the last message! I retraced back to my login and copied the license key. All OK now. Sorry for the false alarm!  Very Happy
Report to moderator   Logged

P-INFO

Posts: 15


[-] Re: The new "Auto-Uploader" system is here!
« Reply #12 on: April 17, 2006, 12:37:59 PM »

Henri,

Amazing job you did .... Uploader worked fine and with the speed of light !

Although I have succesfully used the ioncube version in the past, the autoloader went the other way and installed the zend version, saying it couldn't find the ioncube loaders. Strange huh ?

One or the other, a working version of Snippetmaster PRO 2.0.20 was succesfully installed by the autouploader.

Take care,

Patrick
Report to moderator   Logged
genecap

Posts: 62


WWW
[-] Re: The new "Auto-Uploader" Safe Mode ON
« Reply #13 on: April 17, 2006, 01:20:34 PM »

Using the new autouploader with safe mode on, worked great, I must ftp in and create the subfolder for the data and 777 this subfolder.

minor edits required, not important, just to let you know:
Some of the URL's to the Installation Guide link ,during the install process, to "docs" not documentation
Report to moderator   Logged

.... Gene
halyfax

Posts: 4


[-] Re: The new "Auto-Uploader" system is here!
« Reply #14 on: April 17, 2006, 01:36:04 PM »

after the forst step was complete and files were downloaded the browser tried to fond the autoloader.php and came up with an error, so I just changed the browser url from snippetmaster2/autoloader.php to snippetmaster2 and I could procede with the database info
Report to moderator   Logged
scorpio

Posts: 10


[-] Re: New Autoupdater - "Cannot get it to work!
« Reply #15 on: April 17, 2006, 02:20:14 PM »

« Last Edit: April 18, 2006, 09:05:49 AM by scorpio » Report to moderator   Logged
jbs

Posts: 4


[-] Re: The new "Auto-Uploader" system is here!
« Reply #16 on: April 17, 2006, 02:47:02 PM »

No problems here. This is a great system ... best I've ever seen for installing a script!
Report to moderator   Logged
Papabruin

Posts: 27


[-] Does not work for me
« Reply #17 on: April 18, 2006, 05:30:27 AM »

When I get to...

"Please navigate through the folders below and find your SnippetMaster program folder. (Find the folder where this Auto-Uploader is located.)

The Install Now! button will become enabled once you have selected the correct folder.
Selected folder: "

There are no folders listed below and if I manually type in the path, the "Install Now" button remains ghosted.


(This was on a MAC using Firefox)
« Last Edit: April 18, 2006, 06:14:16 AM by Papabruin » Report to moderator   Logged
andrev

Posts: 21


[-] Re: The new "Auto-Uploader" system is here!
« Reply #18 on: April 18, 2006, 06:54:51 AM »

Hi all
I recently installed the latest beta using the manual method and zend. All went well.

I subsequently tried the autouploader on manual mode and it found ioncube version 3.1 and proceeded to use the ioncube method. I tried this 3 times with the following results. On the first two attempts everything appeared to start well but after a long time (about an hour on the first attempt) I had received no prompt that the files had been uploaded successfully. However when I checked the folder the files were there. But when I tried to start snippetmaster I was told that it could not decode index.php because I did not have the latest version of ioncube. On my 3rd try the files loaded quickly and I was prompted that they had been successfully uploaded. But on trying to start snippermaster I had the same problem with index.php decoding.

I then tried the autouploader in the zend mode. Once again, after a long wait and no prompt confirming successful uploading, I checked the folder and found that the files had been uploaded. I then tried to start snippermaster and this time everything worked perfectly.

Report to moderator   Logged

andre
hmgbird

Posts: 7


WWW
[-] Re: The new "Auto-Installer" system is here!
« Reply #19 on: April 19, 2006, 04:10:27 PM »

I used the Auto-Installer to install the beta. ( I don't recall being asked for my key, but perhaps I was.) I changed the snippet tags to the new ones. When I attempt to load the demo file, the program hangs while trying to load the WHYSIWG editor.

PC using Mozilla, then IE.
Report to moderator   Logged
Pages: [1] Print 
SnippetMaster Support Forums  |  General  |  General Discussion & Support  |  Topic: The new "Auto-Installer" system is here! « previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!