SnippetMaster Support Forums
Return to main website
 
April 21, 2018, 10:51:52 AM
* Show unread posts since last visit.
* Show new replies to your posts.
Welcome, Guest. Please login or register.
Did you miss your activation email?
April 21, 2018, 10:51:52 AM

Login with username, password and session length
Search:  
Advanced search
* Home Help Search Login Register
SnippetMaster Support Forums  |  General  |  General Discussion & Support  |  Topic: Install error « previous next »
Pages: [1] Print
Author Topic: Install error  (Read 9013 times)
wavekiller

Posts: 13


[-] Install error
« on: August 29, 2002, 09:41:56 PM »

Hi guys,

I got a error when I tried to test locally, I cant run it... Crying or Very sad

SnippetMaster v1.0 ERROR
The template named "/snippetmaster/templates/login.html" does not exist
FUNC: useTemplate().

Warning: Failed to Connect in c:\apache\htdocs\snippetmaster\includes\shared.lib.php on line 150

My test system:

Win 32
Apache
PHP 4

Its a "http://localhost" apache test host...

Can you help me please? Sorry, Im not an expert...

Thank you very much!
Report to moderator   Logged

--------8<--------Cut Here--------8<--------

WK.

Only a surfer knows the feeling...
http://Http://www.4surf.com.br
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Install error
« Reply #1 on: August 29, 2002, 09:45:32 PM »

SnippetMaster is designed to run on a unix web server.. and it has never been tested on Windows.

I suspect that if you change the forward slashes for the paths within the program it will work ok for you.  But you'll have to edit the code to do this.

Let me know if it works.
Report to moderator   Logged
wavekiller

Posts: 13


[-] Its works!!!
« Reply #2 on: August 29, 2002, 10:30:53 PM »

hey man, what a quick reply uh? Very Happy !

I just put the the full local path like this "c:/apache/htdocs/site/snippetmaster" at includes/config.inc.php and works fine!

Note: to upload images whithout error you need to set full local path too, aka;
   $UPLOAD_INFO[1][PATH] = "c:/apache/htdocs/site/snippetmaster/upload1";
   $UPLOAD_INFO[1][NAME] = "Upload Location #1";

Well, now you know, it works at win 32 too!

...Its just for test, my remote host is a Redhat Linux, no problem.

Your system is very nice, congratulations! If you need a hand with your project (graphics, templates, and translation) drop me a line.


by well, thank you for your support!  Very Happy

WK.
Report to moderator   Logged

--------8<--------Cut Here--------8<--------

WK.

Only a surfer knows the feeling...
http://Http://www.4surf.com.br
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Install error
« Reply #3 on: August 29, 2002, 10:59:44 PM »

Thanks for testing that out!  I'm glad it seems to working with Windows.. let me know if you encounter any errors or problems.

Cheers!
Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: Its works!!!
« Reply #4 on: August 30, 2002, 12:25:09 AM »

Quote from: wavekiller
If you need a hand with your project (graphics, templates, and translation) drop me a line.


I'm certainly interested in any help I can get!  What can you do?  If you'd like to do some graphics, I could use a logo.  Or a site redesign.  etc..  

See here for more info: http://www.snippetmaster.com/forums/viewtopic.php?t=6
Report to moderator   Logged
wavekiller

Posts: 13


[-] Logo Ideas
« Reply #5 on: August 30, 2002, 07:59:32 AM »

Ok, I will make some graphics and a web template, if you have any idea about a SnippetMaster logo, tell me what you expect and lets see what I can do. Cool

See you later.

WK
Report to moderator   Logged

--------8<--------Cut Here--------8<--------

WK.

Only a surfer knows the feeling...
http://Http://www.4surf.com.br
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: Logo Ideas
« Reply #6 on: August 30, 2002, 09:27:01 AM »

Quote from: wavekiller
Ok, I will make some graphics and a web template, if you have any idea about a SnippetMaster logo, tell me what you expect and lets see what I can do. Cool


Awesome!  

I realy don't have too many ideas for a logo.. I guess something that looks fairly professional and gives a general sense of "YES! I want to use this program!" is what I'm looking for.

Perhaps a background graphic of some HTML or code snippets would be neat.. kind of like how some developer websites have their backgrounds.  I'm really a terrible graphic guy (isn't that obvious? Laughing) and I'm not very clever for ideas like this.. I'm just a coder.   Very Happy

Thanks again!
Report to moderator   Logged
skilgore

Posts: 18


[-] back on topic... ;)
« Reply #7 on: September 04, 2002, 07:56:41 AM »

I have the same issue, On a Redhat server though.

Quote
SnippetMaster v1.0 ERROR
The template named "/var/www/html/snip/templates/login.html" does not exist
FUNC: useTemplate().


But when i try to vi using that path (absolute) login.html is editable.

Any Ideas?

THANKS!
[/quote]
Report to moderator   Logged
sikter

Posts: 7


[-] Install error
« Reply #8 on: September 04, 2002, 12:58:48 PM »

I'm getting the following error on the unix machine:

SnippetMaster v1.0 ERROR
The template named "home/endeavor/public_html/editor/admin/templates/login.html" does not exist
FUNC: useTemplate().

I checked the paths and they are OK. All files are there!?
This will be a killer when everything starts working OK.

Any suggestions?

Thanks.

Sik
Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Install error
« Reply #9 on: September 04, 2002, 06:11:06 PM »

OK.. I made a few changes, can you re-download the zip file and see if the problem still exists?  Let me know if it's fixed.

Thanks!
Report to moderator   Logged
skilgore

Posts: 18


[-] Install error
« Reply #10 on: September 05, 2002, 03:02:27 PM »

Ok, I'm uploading the new one now, I'll tell you how it works.

BTW, I found out my actual absolute path (not my virtual one) and that fixed the first problem, but then i got the template issue talked about in a different thread.
Report to moderator   Logged
skilgore

Posts: 18


[-] Install error
« Reply #11 on: September 05, 2002, 03:04:53 PM »

ok, well i fixed my first problem with the aforementioned directory change, so my folders are now set to

/home/virtual/site8/fst/var/www/html

and i dont have this problem anymore (fixed before 1.01) but im getting hte template issue, so i'll go p[ost in the other thread THANKS!
Report to moderator   Logged
Pages: [1] Print 
SnippetMaster Support Forums  |  General  |  General Discussion & Support  |  Topic: Install error « previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!