SnippetMaster Support Forums
Return to main website
 
January 17, 2018, 11:40:02 PM
* Show unread posts since last visit.
* Show new replies to your posts.
Welcome, Guest. Please login or register.
Did you miss your activation email?
January 17, 2018, 11:40:02 PM

Login with username, password and session length
Search:  
Advanced search
* Home Help Search Login Register
SnippetMaster Support Forums  |  General  |  Installation Issues  |  Topic: SM, Zend and PHP5.4 « previous next »
Pages: [1] Print
Author Topic: SM, Zend and PHP5.4  (Read 2451 times)
Schizolocal

Posts: 3


[-] SM, Zend and PHP5.4
« on: February 10, 2014, 10:02:35 AM »

Is it the case that Snippetmaster expects Zend Optimizer, and PHP5.4 uses Zend Guard Loader instead, so that the required combination is doomed?

I am trying to install SM to work on my local Windows-based webserver, which I recently upgraded (after some sweat) to PHP5.4. And I can't get Zend to appear in my PHPinfo (Zend Optimizer stopped at 5.2 I believe), so do I have to have a complete Zend Server installation or what?

(By the way, my eventual client may well have a different configuration, so I am eager to solve this generically)

Stuart
Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: SM, Zend and PHP5.4
« Reply #1 on: February 10, 2014, 10:38:51 AM »

Zend stopped making the Optimizer product for PHP 5.4.  So you should use the Ioncube version instead, which will work with all versions of Windows. Smile

If you get stuck, let me know.

Cheers!
Report to moderator   Logged
Schizolocal

Posts: 3


[-] Re: SM, Zend and PHP5.4
« Reply #2 on: February 10, 2014, 12:29:03 PM »

Thanks for your very prompt reply (both, actually). I'll look into IonCube.

Stuart
Report to moderator   Logged
Pages: [1] Print 
SnippetMaster Support Forums  |  General  |  Installation Issues  |  Topic: SM, Zend and PHP5.4 « previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!