SnippetMaster Support Forums
Return to main website
 
April 19, 2018, 08:50:38 PM
* Show unread posts since last visit.
* Show new replies to your posts.
Welcome, Guest. Please login or register.
Did you miss your activation email?
April 19, 2018, 08:50:38 PM

Login with username, password and session length
Search:  
Advanced search
* Home Help Search Login Register
SnippetMaster Support Forums  |  General  |  Installation Issues  |  Topic: Not seeing an installation wizard after automatic install « previous next »
Pages: [1] Print
Author Topic: Not seeing an installation wizard after automatic install  (Read 7806 times)
milimar

Posts: 2


[-] Not seeing an installation wizard after automatic install
« on: December 05, 2011, 06:20:10 AM »

After a successful automatic install, when I click on START INSTALLATION WIZARD I see only a blank page.
My purpose of installing SnippetMaster is to learn how it works, so I use a free server offered by freewebhostingarea.com.
Any suggestions?

Thank you!
Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: Not seeing an installation wizard after automatic install
« Reply #1 on: December 05, 2011, 06:23:19 AM »

I think you just sent me an email?

It looks like the freewebhostingarea.com server you are using does not support Ioncube Loaders.  The Ioncube Loaders are required by SnippetMaster to decode the program files...

I will take a look more into this and see if perhaps the Ioncube.com people can provide a version of the loader files that works with this hosting provider.  I'll let you know...
Report to moderator   Logged
milimar

Posts: 2


[-] Re: Not seeing an installation wizard after automatic install
« Reply #2 on: December 05, 2011, 06:37:55 AM »

Thank you for your fast answer!
Well yes, I just sent you a request for installation, and I am going to send you then another one for another free hosting server. There I could not even finish the automatic installation, because when I click the button INSTALL a download window appears to download autoinstaller.php from my server.
Report to moderator   Logged
deliwasista

Posts: 33


[-] Re: Not seeing an installation wizard after automatic install
« Reply #3 on: December 12, 2011, 05:06:26 PM »

Im having the same problem.. ive several other sites using snippetmaster and they all are fine (all using the same host provider) but all of a sudden with this new installation on a new site I cant seem to get past the file installation.. im using ioncube as my provider doesnt like the zend files...

I have also emailed you for an installation on this one.. was hoping to have done before kids got off for school break! oops. shouldnt have left this job till last :/
Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: Not seeing an installation wizard after automatic install
« Reply #4 on: December 12, 2011, 10:55:05 PM »

Hello,

I'll send a reply to your email about this.  Smile
Report to moderator   Logged
deliwasista

Posts: 33


[-] Re: Not seeing an installation wizard after automatic install
« Reply #5 on: December 13, 2011, 11:50:32 AM »

Hi thank you so much for fixing it Smile so far so good - I can now get to the admin panel with no problems.  Can you let me know what you did to fix this so if it happens again I can remedy it without hassling you  Razz
Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: Not seeing an installation wizard after automatic install
« Reply #6 on: December 13, 2011, 11:58:45 AM »

The ioncube loaders needed to be installed using a "php.ini" file in each folder where a .php file exists.  Smile

Report to moderator   Logged
deliwasista

Posts: 33


[-] Re: Not seeing an installation wizard after automatic install
« Reply #7 on: December 13, 2011, 12:19:11 PM »

So if this were to happen again during an automatic install on another site and I were to copy the "php.ini" file you have placed on this server over to the problematic one in its entirety (and into each sub folder containing a .php file) then it should be all good?. 

Just out of interest where did you get the "php.ini" file from - does it come in the manual download of the snippetmaster?
Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: Not seeing an installation wizard after automatic install
« Reply #8 on: December 13, 2011, 12:22:22 PM »

No, the problem is that the Ioncube Loaders on your website will not work without a special "php.ini" file.  This file was created by the Ioncube Loader "install wizard" that I used to install the loaders on your website.  It is from ioncube.com/loaders.php

An easier solution is to ask your hosting provider to install the Ioncube Loaders for you.  Any good hosting provider should do this for you in 10 seconds, as it's standard hosting software on any shared hosting server. 

Then you won't have to worry about the ioncube loader stuff at all.  Smile

Report to moderator   Logged
deliwasista

Posts: 33


[-] Re: Not seeing an installation wizard after automatic install
« Reply #9 on: December 13, 2011, 12:29:56 PM »

Superb  Cool thanks so much - and yes I thought it was odd that all the others have worked no problems! host must be slacking off now that its egg nog season ..  righty head down tail up - only four more sites to go! thanks so much for your speedy reply  Very Happy
Report to moderator   Logged
flapjacks

Posts: 4


[-] Re: Not seeing an installation wizard after automatic install
« Reply #10 on: February 14, 2012, 12:30:24 AM »

I'm having this problem as well. 

I've installed Snippetmaster on a couple of sites on the same server successfully but I just tried to install this on a new site and I can't get to the admin.php page once install is complete. 

Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: Not seeing an installation wizard after automatic install
« Reply #11 on: February 14, 2012, 12:32:54 AM »

What happens when you click the admin link?

Note, that the "starting" login page for snippetmaster is /snippetmaster/index.php and NOT /snippetmaster/admin.php

You should never directly access the admin.php file.  It should be called by clicking on the "admin" link after you login.

Let me know. Smile
Report to moderator   Logged
flapjacks

Posts: 4


[-] Re: Not seeing an installation wizard after automatic install
« Reply #12 on: February 14, 2012, 12:35:11 AM »

Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: Not seeing an installation wizard after automatic install
« Reply #13 on: February 14, 2012, 12:58:37 AM »

A blank page typically means there is a problem with the Ioncube Loaders or Zend Optimizer (depending on which encoding type of Snippetmaster you are using). 

I'm happy to try a free install to see if I can get this working for you:

http://www.snippetmaster.com/download/index.php#free_install

Report to moderator   Logged
flapjacks

Posts: 4


[-] Re: Not seeing an installation wizard after automatic install
« Reply #14 on: February 14, 2012, 01:10:37 AM »

Thanks.  Just filled out the form. 

Is there a reason it worked before but not now? 

I'd like to contact my host and see if they can help me.  The more info the better. 

Thanks again.  I really love this software!  I've licensed about 5 or so copies. 


Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: Not seeing an installation wizard after automatic install
« Reply #15 on: February 14, 2012, 01:14:28 AM »

OK, I will reply to you via email so we can work together and figure out the problems.  Smile

Report to moderator   Logged
Pages: [1] Print 
SnippetMaster Support Forums  |  General  |  Installation Issues  |  Topic: Not seeing an installation wizard after automatic install « previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!