SnippetMaster Support Forums
Return to main website
 
January 16, 2018, 07:50:05 AM
* Show unread posts since last visit.
* Show new replies to your posts.
Welcome, Guest. Please login or register.
Did you miss your activation email?
January 16, 2018, 07:50:05 AM

Login with username, password and session length
Search:  
Advanced search
* Home Help Search Login Register
SnippetMaster Support Forums  |  General  |  Installation Issues  |  Topic: Auto upgrade didn't work « previous next »
Pages: [1] Print
Author Topic: Auto upgrade didn't work  (Read 3897 times)
bikeman

Posts: 21


[-] Auto upgrade didn't work
« on: October 27, 2006, 07:38:42 AM »

function.ftp-put]: PORT command successful in /homepages/0/d759789/htdocs/smlite_test/cms/autoinstaller.php on line 147
Error transfering the includes/tiny_mce/plugins/flash/css/content.css file.
Note: If the error above is something like Warning: ftp_put(): PORT command successful in ... on line 1', then try restarting the Auto-Installer and CHECKING the 'Use PASV Mode?' option.

You should also make sure there is enough disk space remaining.

A problem was found. I will now clean up anything done so far...

The Auto-Installer did not work.
(Please review the error(s) above. Maybe it's a problem you can fix?)


I have tried both with and without pasv checked.
« Last Edit: October 27, 2006, 07:50:19 AM by bikeman » Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: Auto upgrade didn't work
« Reply #1 on: October 28, 2006, 11:44:11 AM »

Can you try it again using Passive mode for FTP? 

If the autoinstaller did work previously, then it's likely something has changed on your web server.  Maybe ask your web host if they've changed anything?

Let me know how it goes.  If all else fails, you can always "manually" upload all the files.  Smile

Report to moderator   Logged
bikeman

Posts: 21


[-] Re: Auto upgrade didn't work
« Reply #2 on: October 29, 2006, 01:55:35 AM »

In my previous post I said that I have tried both with and without pasv checked.

It's not a very practical suggestion to ask my host if they have changed anything as I installed SM over 6 months ago - I am sure they have changed lots of things since then! Do you have anything specific I should ask them?

I am pretty sure that I posted a followup post which stated that when I used this upgrade it did something which my host server didn't like whcih resulted in it blacklisting my ISPs proxy server. I have discussed this with both my host and my ISP and they haven't really got to the bottom of what happened. The situation now is that as long as my host continues to do this I and everyone else on my ISP cannot access any of my domains unless they manually add a differnt proxy address (which obviusly most users will be unaware of this and just think the domains re down). Suffice to say I am not terribly impressed.
Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: Auto upgrade didn't work
« Reply #3 on: October 29, 2006, 02:40:46 AM »

Well, to be honest, I'm not terribly impressed with your host, then.  Smile

The autoinstaller uses regular "ftp functions" of PHP to upload the files.  It simply creates a normal FTP connection, and then uploads the files, just like if you did it with a regular FTP client from your own computer.  There is nothing unusual or special.

It might not work if your server does not allow the FTP functions of PHP to work properly, or if your host has not correctly configured their servers, or they are using an old version of PHP that doesn't have the functions, or they are just overly paranoid and have disabled FTP functions for php, etc... 

With regard to your web host or ISP blacklisting your IP or something... that's just crazy.  If they're doing that, then you should find a different web host immediately.

I've heard of some web hosts who automatically block an IP address that tries to connect "too fast".  This might be what is happening for you?  You see, the PHP software (the autoinstaller) is trying to connect to the same server where the software is running, using FTP functions, and since it's on the same server... the connections are happening very very fast.  (Because there is no network travel, etc..)  So if your ftp server is not able to keep up with this (ie: It's overloaded server or configured not to allow fast connections, or just poorly configured), then it might have a problem.

I'm not sure what you expect me to do here, because the problem is with your web host.  The autoinstaller is using nothing but standard FTP functions included in PHP.  There is nothing unusual or special. 

If your web host or ISP or whatever is not going to allow you to use FTP from within a PHP program that is running on the same server, then you'll need to upload the files using a different ftp method.. (ie: Use a normal ftp program like "cuteftp" or "ftp_ws", etc.)

I recommend asking your web host how they expect you to get the files from your computer to their server.  Then do whatever they suggest.  The autoinstaller is provided as a "built-in" ftp program specifically to get the latest snippetmaster files from the snippetmaster website and put them on your server.  But if your web host or ISP doesn't allow this to work, then you can just do it "manually" yourself. 

here's the link for instructions:

http://www.snippetmaster.com/download/manual-install.php

Report to moderator   Logged
admin
Forum Administrator
*
Posts: 3169

SnippetMaster Author


WWW
[-] Re: Auto upgrade didn't work
« Reply #4 on: October 29, 2006, 02:46:46 AM »

Also, keep in mind that I do offer a free installation service if you get stuck with anything:

http://www.snippetmaster.com/download/index.php#freeinstall

Smile
Report to moderator   Logged
bikeman

Posts: 21


[-] Re: Auto upgrade didn't work
« Reply #5 on: October 29, 2006, 06:11:30 AM »

I'll try the manual upgrade.

BTW my host is 1and1. They are a big player and usually very good at configuring their servers (but unfortunately poor at support so they're not perfect). I used the auto install at 2.1 with them and it worked fine so I am not sure why I have a problem with 2.2

I have past experience of 1and1 blocking out my own ip address when I try to ftp too fast or with too many threads but never have they blacklisted an ISPs ip address. I am not actually sure they have even done this since my ISP is NTL and a quick search fo the internet finds loads of posts re NTL have problems with hosts blacklisting their proxy servers.

Unfortunately support from both 1and1 and NTL isn't great so I dont expect to ever get to the bottom of this. Bottom line is betwen your auto install script, 1and1 and NTL something is messing up. I shall just make a note to avoid the auto upgrade in future.

Thanks anyway 
Report to moderator   Logged
Pages: [1] Print 
SnippetMaster Support Forums  |  General  |  Installation Issues  |  Topic: Auto upgrade didn't work « previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!